Problemas con VoIP y SIP ALG en módem de Claro El Salvador [RESUELTO]

Escrito por el Friday 28 de June de 2013 y archivado como Portada, Software. Puedes seguir los comentarios por medio de RSS 2.0. Participa dejando un comentario y no olvides hacerlo siempre con respeto ya que aparecen publicados automáticamente. Lecturas: 11338

Voy a escribir este post un poco rápido porque tengo poco tiempo. Para los ententidos y para los aventurados espero que este post sea de mucha ayuda.

Resulta que tengo contratado un servicio de telefonía VoIP en la oficina con la compañía Red 4G y recientemente cambiamos de proveedor de internet (de Tigo a Claro) y mi servicio de VoIP dejó de funcionar.

Realmente no es que haya dejado de funcionar sino más bien es que el módem Eltel E-5300 que da Claro (uno negrito, que es básicamente un Comtrend) tiene en su configuración por defecto que mutea el tono del teléfono y uno cree que no funciona (lo cuál técnicamente no es así pero en la práctica no podemos escuchar ni la gente del otro lado nos escucha).

Para resolver este problema hay que entrar por cable de red al dichoso router con la dirección 192.168.1.1 usuario: admin y contraseña: c1@r0

eltel1

Luego de entrar ir a la pestaña Maintenance y luego en el segundo botón de abajo Configuration Backup y les va a descargar un archivo que se llama romfile.cfg.

Con Wordpad abren el archivo y guardan una copia por cualquier cosa y cambian los siguiente, más bien asegúrense de que esté con los valores a continuación:

<Alg>
	<Entry SiproxdEnable="No" />
	<Siproxd Enable="No" outbound="2" />
</Alg>

Más adelante revisar:

<VoIPAdvanced> 	<Common SIPBinding="Wan" pvcId="0" VoIPRegion="SLV-El Salvador"
DTMFTransportMode="Inband" FaxCodec="T38" RegistrationExpire="3600" />
	<Entry0 VoiceVolumeListen="<strong>100</strong>" VoiceVolumeSpeak="<strong>100</strong>" />
	<Entry1 VoiceVolumeListen="<strong>100</strong>" VoiceVolumeSpeak="<strong>100</strong>" />
</VoIPAdvanced>
<VoIPBasic> 	<Common SIPProxyEnable="<strong>No</strong>" SIPProxyAddr=""
SIPProxyPort="" SIPOutboundProxyEnable="<strong>No</strong>" SIPOutboundProxyAddr=""
SIPOutboundProxyPort="" SIPTransportProtocol="UDP" LocalSIPPort="5060"
LocalRTPPort="4000" VoIPLine2Eanble="No" ForbiddenWeb="1" />
	<Entry0 SIPEnable="No" SIPDisplayName="" SIPAuthenticationName=""
SIPPassword="" />
	<Entry1 SIPEnable="No" SIPDisplayName="" SIPAuthenticationName=""
SIPPassword="" />
</VoIPBasic>
<VoIPCallCtrl> 	<Entry0 SIPCallerIdEnable="Yes" SIPCallWaitingEnable="Yes"
SIPCallForwardEnable="No" SIPCFUNumber="*11" SIPCFBNumber="*12"
SIPCFNRNumber="*13" SIPCallTransfer="No" SIPBlindTransferNumber="*21"
SIPAttendedTransferNumber="*22" SIP3wayConf="No" SIP3wayConfNumber="*3"
SIPMWIEnable="No" SIPCallReturnEnable="No" SIPCallReturnNumber="*69"
AnonymousCall="Yes" AnonymousCallBlock="No" SIPDNDEnable="No"
SIPDNDEnableNumber="*78" SIPDNDDisableNumber="*79" DODEnable="No"
DODNumber="*0" />
	<Entry1 SIPCallerIdEnable="Yes" SIPCallWaitingEnable="Yes"
SIPCallForwardEnable="No" SIPCFUNumber="*11" SIPCFBNumber="*12"
SIPCFNRNumber="*13" SIPCallTransfer="No" SIPBlindTransferNumber="*21"
SIPAttendedTransferNumber="*22" SIP3wayConf="No" SIP3wayConfNumber="*3"
SIPMWIEnable="No" SIPCallReturnEnable="No" SIPCallReturnNumber="*69"
AnonymousCall="Yes" AnonymousCallBlock="No" SIPDNDEnable="No"
SIPDNDEnableNumber="*78" SIPDNDDisableNumber="*79" DODEnable="No"
DODNumber="*0" />
</VoIPCallCtrl>

Guardar como, que la extensión sea .cfg y luego a subirlo y actualizar. Su VoIP estará ready para usar.
El problema que no he logrado resolver es el del ringback tone que es el tono que quien llama escucha (y que coincide con el ring cuando timbra el teléfono que recibe la llamada). No sé si este es problema del operador o de configuración del módem pero tiene que ver con que o no se envía o no se transforma/convierte bien el impulso H.262 del concentrador/operador.

Para verificar se van a Advanced Setup / NAT y ya no les aparece la opción SIP ALG.

eltel2

Mi hardware VoIP es un Linksys RTP300 y pues es muy probable que este método sirva para otros modem-router. Pueden intentarlo por Telnet o SSH.

Para los estudioso:
SIP: Session Initiaton Protocol
ALG: Aplication Layer Gateway
VoIP: Voice over IP
Puerto que utiliza SIP: 5060

Saludos.

Blog Widget by LinkWithin

4 Respuestas a “Problemas con VoIP y SIP ALG en módem de Claro El Salvador [RESUELTO]”

  1. Linux Inside says:

    Está super bueno el post. Ni me imaginaba que con los modems de claro se podria configurar bien VoIP y SIP jaja.. me llega, exitos.

  2. Gerardo Paredes says:

    Tu implementacion me sirvió al 100%, y eso que lo estoy aplicando para Guatemala.

    Saludos y Exitos!!!

  3. Remnts says:

    Excelente post amigo, ya me habia dado por vencido con este router mi servicio Voip no funcionaba en lo absoluto.
    Gracias por el aporte ha sido de gran ayuda!
    Saludos

  4. Melvin Castillo says:

    Esto se prodria hacer para la liberación de puertos…. ???

Deja un Comentario